MKV Audio Problem

MKV playback, recompression, remuxing, codec packs, players, howtos, etc.
Post Reply
bealefay
Posts: 2
Joined: Mon Feb 10, 2020 2:48 am

MKV Audio Problem

Post by bealefay » Mon Feb 10, 2020 6:58 am

built a new HTPC with an AMD chipset running the latest version of Windows 10. I’ve got a weird problem with the audio in MKVs.

My HTPC is connected to my Sony STR-DN1040 via HDMI. I’ve ripped a couple of my blu rays to MKV using MakeMKV, and I’ve used MediaInfo to verify that the audio streams ripped lossless (passthru) in their native format.

But no matter which player I use - VLC or WMP Classic, the audio is coming to my receiver as PMC Linear 2.0.

When I play the very same disc in my dedicated blu ray player, without changing any settings on my receiver, the audio comes through as Dolby Digital and DTS.

My receiver is set to auto-detect the stream.

This seems to be a problem only with MKVs, because if I play a ripped movie in BDMV format, the audio passes thru fine.

It’s really weird! Any ideas? This also isn’t a problem with MakeMKV because I’m experiencing the same problem using a different MKV ripper.

Billycar11
Posts: 1125
Joined: Sun Aug 24, 2014 5:49 am

Re: MKV Audio Problem

Post by Billycar11 » Thu Feb 13, 2020 7:02 pm

Make sure you enable passthrough or bitstreaming in your playback software and have allow exclusive control on your windows sound settings for that playback device.

bealefay
Posts: 2
Joined: Mon Feb 10, 2020 2:48 am

Re: MKV Audio Problem

Post by bealefay » Mon Sep 21, 2020 7:54 am

Billycar11 wrote:
Thu Feb 13, 2020 7:02 pm
Make sure you enable passthrough or bitstreaming in your playback software and have allow exclusive control on your windows sound settings for that playback device.
thanks ;)

Post Reply